Back to overview
Resolved
Conversations still may not load; back shortly
Jun 11, 2026 at 11:37am UTC
Affected services
TourOptima System Health
Resolved
Jun 11, 2026 at 11:40am UTC
Fully back across all accounts.
Affected services
Created
Jun 11, 2026 at 11:37am UTC
We are still in the process of restoring services for all clients and conversations should load shortly. Will post again when fully restored for all.
Affected services